summaryrefslogtreecommitdiff
path: root/Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Yun <joshua@joshuayun.com>2025-03-13 23:16:14 -0500
committerJoshua Yun <joshua@joshuayun.com>2025-03-13 23:16:14 -0500
commit2b4e742f021a37fffcc5e557c4456c0a4ea77483 (patch)
tree2db677efc1bbe14149d4248dca61969cffa9e1c1 /Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
parent3ecbe307fbdbede75d8b66d50244c0f4260a8774 (diff)
downloadsdr-master.tar.gz
fix: software was accidentally a submoduleHEADmaster
Diffstat (limited to 'Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt')
-rw-r--r--Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt b/Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
new file mode 100644
index 0000000..130b4a0
--- /dev/null
+++ b/Software/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required (VERSION 3.6)
+
+project(CMSISDSPCommon)
+
+
+
+add_library(CMSISDSPCommon STATIC arm_common_tables.c)
+
+if (CONFIGTABLE AND ALLFFT)
+ target_compile_definitions(CMSISDSPCommon PUBLIC ARM_ALL_FFT_TABLES)
+endif()
+
+if (CONFIGTABLE AND ALLFAST)
+ target_compile_definitions(CMSISDSPCommon PUBLIC ARM_ALL_FAST_TABLES)
+endif()
+
+include(fft)
+fft(CMSISDSPCommon)
+
+include(interpol)
+interpol(CMSISDSPCommon)
+
+target_sources(CMSISDSPCommon PRIVATE arm_const_structs.c)
+
+configdsp(CMSISDSPCommon ..)
+
+### Includes
+target_include_directories(CMSISDSPCommon PUBLIC "${DSP}/../../Include")
+
+
+