summaryrefslogtreecommitdiff
path: root/Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Yun <joshua@joshuayun.com>2025-03-13 23:16:14 -0500
committerJoshua Yun <joshua@joshuayun.com>2025-03-13 23:16:14 -0500
commit2b4e742f021a37fffcc5e557c4456c0a4ea77483 (patch)
tree2db677efc1bbe14149d4248dca61969cffa9e1c1 /Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt
parent3ecbe307fbdbede75d8b66d50244c0f4260a8774 (diff)
downloadsdr-master.tar.gz
fix: software was accidentally a submoduleHEADmaster
Diffstat (limited to 'Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt')
-rw-r--r--Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt b/Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt
new file mode 100644
index 0000000..34cdd8d
--- /dev/null
+++ b/Software/Drivers/CMSIS/DSP/Source/ComplexMathFunctions/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required (VERSION 3.6)
+
+project(CMSISDSPComplexMath)
+
+
+file(GLOB SRC "./*_*.c")
+
+add_library(CMSISDSPComplexMath STATIC ${SRC})
+
+configdsp(CMSISDSPComplexMath ..)
+
+### Includes
+target_include_directories(CMSISDSPComplexMath PUBLIC "${DSP}/../../Include")
+
+
+