summaryrefslogtreecommitdiff
path: root/slstatus.h
Commit message (Collapse)AuthorAgeFilesLines
* feat: pamixer status bar for volumeJoshua Yun4 days1-0/+1
|
* Sort functions by nameplanet362022-12-191-3/+3
| | | | | Co-authored-by: drkhsh <me@drkhsh.at> Signed-off-by: drkhsh <me@drkhsh.at>
* New component: catdrkhsh2022-11-241-0/+3
| | | | | | | Generically reads an arbitrary file natively. Saves a few layers of execution in comparison to using `run_command` with an argument like `cat ./file`.
* separator: kill that useless thingdrkhsh2022-10-281-3/+0
| | | | Just use the format strings dude. :)
* do not rely on obsolete featureNRK2022-10-261-19/+19
| | | | | | | | | | function prototype with unspecified argument is obsolete since c99. additionally some of these function which don't take any argument were being called with a `const char *` arg, which is UB. fix both these issues by declararing ALL the components to accept a `const char *`, and name the arg "unused" if it's meant to be ignored.
* Fix keyboard_indicators() prototypeNRK2022-10-261-1/+1
| | | | | according to both the function definition and the comment in config.def.h, keyboard_indicators() should take a format string.
* Add separator moduleRyan Kes2020-11-301-0/+3
|
* Consistent paramter naming for componentsAaron Marcher2018-07-061-9/+9
|
* slstatus.h: Fix coding styleAaron Marcher2018-07-061-16/+16
| | | | | | Function declarations should include variable names. For functions with different parameters on different platfroms they are left out.
* Revert "Add basic backlight percentage support"Aaron Marcher2018-05-271-3/+0
| | | | | | | | | | | | On OpenBSD the backlight percentage cannot be retrieved in a simple way. The only two solutions we are aware of for now are: - reading from /dev/ttyC0: which isn't possible without changing permissions or running slstatus as root - linking against xcb-xrandr: which is bloat and does not work in every case appearently This reverts commit 37724ac2c3f496f4736223d0d8e5d8fecb933590 for now.
* Add keymap componentMichael Buch2018-05-231-0/+3
| | | | | | | | Adding a new keymap component that will indicate the current keyboard layout (language) and variant if any was set. I use the standard X11 XKB APIs to retrieve and parse the xkb_symbols set with setxkbmap.
* Add basic backlight percentage supportDavid Demelier2018-05-221-0/+3
| | | | At the moment linux only, but will add support for OpenBSD as well.
* Add network speed functionsAaron Marcher2018-05-191-0/+4
|
* Add battery_remaining function on OpenBSDTobias Tschinkowitz2018-05-181-0/+1
| | | | | | | Implementation of a battery_remaining function which returns the remaining battery time in HH:MM format. Linux function still needs implementation. Move common code to load_apm_power_info
* Remove cpu_iowaitAaron Marcher2018-05-061-1/+0
| | | | | | The third value from load_avg (idle) gives us almost the same information as cpu_iowait. Plus OpenBSD does not offer an iowait value as Linux and thus the corresponding function would not be portable.
* Remove battery_power for various reasonsAaron Marcher2018-05-011-1/+0
| | | | | - Battery power cannot be easily gatherable via apm(4) - IMHO it does not represent essential information
* Rewrite Makefile to accomodate file splitLaslo Hunhold2017-09-171-0/+75
|
* suckless coding style fix -> remove slstatus.hAaron Marcher2016-08-181-40/+0
|
* added uptime functionAaron Marcher2016-08-181-0/+1
|
* load avgAaron Marcher2016-08-181-0/+1
|
* Formatting commit :(Aaron Marcher2016-08-161-3/+3
| | | | | | | | | | | I know formatting commits suck... And I try to avoid them. But this commit was absolutely necessary... The coding style in this program was not ok and not the same over the whole program. The commit is hard to read, but this is what I changed: - Tabs for indentation instead of spaces - Same style over the whole program (suckless style)
* added wifi essidAaron Marcher2016-08-151-0/+1
|
* Fixed alsa function + datetime functionAaron Marcher2016-08-151-0/+1
|
* added, username, gid, uidAaron Marcher2016-06-131-0/+3
|
* added disk functions for detailsAaron Marcher2016-06-101-0/+3
|
* added memory values ram functionsAaron Marcher2016-06-101-0/+3
|
* hostname functionAaron Marcher2016-06-101-0/+1
|
* added ip address functionAaron Marcher2016-06-081-0/+1
|
* added entropyAaron Marcher2016-06-031-0/+1
|
* Easier info function namesAaron Marcher2016-03-181-8/+8
| | | | | | | | All the info function names started with "get_", which I removed to make it easier for the user to configure the program to its needs. Additionally I renamed some functions (e.g. get_ram_usage) to better names, making it easier to extend the program with ram usage / total functions.
* added license info to slstatus.hAaron Marcher2016-03-161-0/+2
|
* headerAaron Marcher2016-03-161-0/+22