aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-04 21:06:58 -0600
committerDaniel Eklöf <daniel@ekloef.se>2024-06-12 20:13:43 +0200
commit2ccd1b1099eb32f57a6fb3b91bfc2f8ed3fc1bca (patch)
treea6992b101c1ca950d48aa66a50b31035be558c16 /meson.build
parent573c014568a7dd4facbca9cc6b9032996c18338e (diff)
downloadwbg-2ccd1b1099eb32f57a6fb3b91bfc2f8ed3fc1bca.tar.gz
jxl: add initial support for JPEG XL using libjxl
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 16 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index eaac74a..ea310ca 100644
--- a/meson.build
+++ b/meson.build
@@ -51,6 +51,8 @@ pixman = dependency('pixman-1')
png = dependency('libpng', required: get_option('png'))
jpg = dependency('libjpeg', required: get_option('jpeg'))
webp = dependency('libwebp', required: get_option('webp'))
+jxl = dependency('libjxl', required: get_option('jxl'))
+jxl_threads = dependency('libjxl_threads', required: false)
svg = declare_dependency(
sources: ['nanosvg.c', '3rd-party/nanosvg/src/nanosvg.h',
'nanosvgrast.c', '3rd-party/nanosvg/src/nanosvgrast.h'],
@@ -59,7 +61,7 @@ svg = declare_dependency(
)
have_svg = get_option('svg')
-if not png.found() and not jpg.found() and not webp.found() and not have_svg
+if not png.found() and not jpg.found() and not jxl.found() and not webp.found() and not have_svg
error('you must enable at least one image format')
endif
@@ -75,6 +77,14 @@ endif
if have_svg
add_project_arguments('-DWBG_HAVE_SVG=1', language:'c')
endif
+if jxl.found()
+ add_project_arguments('-DWBG_HAVE_JXL=1', language:'c')
+ if jxl_threads.found()
+ add_project_arguments('-DWBG_HAVE_JXL_THREADS=1', language:'c')
+ endif
+else
+ jxl_threads = dependency('', required: false)
+endif
wayland_protocols = dependency('wayland-protocols')
wayland_client = dependency('wayland-client')
@@ -121,6 +131,9 @@ endif
if jpg.found()
image_format_sources += ['jpg.c', 'jpg.h']
endif
+if jxl.found()
+ image_format_sources += ['jxl.c', 'jxl.h']
+endif
if webp.found()
image_format_sources += ['webp.c', 'webp.h']
endif
@@ -136,13 +149,14 @@ executable(
'stride.h',
image_format_sources,
wl_proto_src + wl_proto_headers, version,
- dependencies: [pixman, png, jpg, webp, svg, wayland_client, tllist],
+ dependencies: [pixman, png, jpg, jxl, jxl_threads, webp, svg, wayland_client, tllist],
install: true)
summary(
{
'PNG support': png.found(),
'JPEG support': jpg.found(),
+ 'JPEG XL support': jxl.found(),
'WebP support': webp.found(),
'SVG support': have_svg
},