aboutsummaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
authoradnano <me@adnano.co>2022-01-16 08:32:58 -0500
committeradnano <me@adnano.co>2022-01-16 08:32:58 -0500
commit2f1c189d535c2d8dce74ec44c670305f00e4a30c (patch)
tree79811ea0ebe16d28b4bd7bfe2cff1db1977919db /docs/meson.build
downloadwmenu-2f1c189d535c2d8dce74ec44c670305f00e4a30c.tar.gz
Initial commit
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
new file mode 100644
index 0000000..4ccfe49
--- /dev/null
+++ b/docs/meson.build
@@ -0,0 +1,26 @@
+scdoc_dep = dependency('scdoc', version: '>=1.9.2', native: true)
+
+if scdoc_dep.found()
+ scdoc = find_program(
+ scdoc_dep.get_pkgconfig_variable('scdoc'),
+ native: true,
+ )
+ mandir = get_option('mandir')
+
+ docs = [
+ 'wmenu.1',
+ ]
+
+ foreach path : docs
+ custom_target(
+ path,
+ output: path,
+ input: '@0@.scd'.format(path),
+ capture: true,
+ feed: true,
+ command: [scdoc],
+ install: true,
+ install_dir: '@0@/man1'.format(mandir)
+ )
+ endforeach
+endif