aboutsummaryrefslogtreecommitdiff
path: root/protocols/meson.build
diff options
context:
space:
mode:
authoradnano <me@adnano.co>2022-01-16 08:32:58 -0500
committeradnano <me@adnano.co>2022-01-16 08:32:58 -0500
commit2f1c189d535c2d8dce74ec44c670305f00e4a30c (patch)
tree79811ea0ebe16d28b4bd7bfe2cff1db1977919db /protocols/meson.build
downloadwmenu-2f1c189d535c2d8dce74ec44c670305f00e4a30c.tar.gz
Initial commit
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build47
1 files changed, 47 insertions, 0 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
new file mode 100644
index 0000000..083099a
--- /dev/null
+++ b/protocols/meson.build
@@ -0,0 +1,47 @@
+wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
+
+wayland_scanner_dep = dependency('wayland-scanner', required: false, native: true)
+if wayland_scanner_dep.found()
+ wayland_scanner = find_program(
+ wayland_scanner_dep.get_pkgconfig_variable('wayland_scanner'),
+ native: true,
+ )
+else
+ wayland_scanner = find_program('wayland-scanner', native: true)
+endif
+
+protocols = [
+ [wl_protocol_dir, 'unstable/xdg-output/xdg-output-unstable-v1.xml'],
+ [wl_protocol_dir, 'stable/xdg-shell/xdg-shell.xml'],
+ ['wlr-layer-shell-unstable-v1.xml'],
+]
+
+wl_protos_src = []
+wl_protos_headers = []
+
+foreach p : protocols
+ xml = join_paths(p)
+ wl_protos_src += custom_target(
+ xml.underscorify() + '_protocol_c',
+ input: xml,
+ output: '@BASENAME@-protocol.c',
+ command: [wayland_scanner, 'private-code', '@INPUT@', '@OUTPUT@'],
+ )
+ wl_protos_headers += custom_target(
+ xml.underscorify() + '_client_h',
+ input: xml,
+ output: '@BASENAME@-client-protocol.h',
+ command: [wayland_scanner, 'client-header', '@INPUT@', '@OUTPUT@'],
+ )
+endforeach
+
+lib_client_protos = static_library(
+ 'client_protos',
+ wl_protos_src + wl_protos_headers,
+ dependencies: wayland_client.partial_dependency(compile_args: true),
+)
+
+client_protos = declare_dependency(
+ link_with: lib_client_protos,
+ sources: wl_protos_headers,
+)