aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 24 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fc4a2c0..552e1f8 100644
--- a/meson.build
+++ b/meson.build
@@ -38,12 +38,35 @@ install_data('wmenu_run', install_dir: get_option('bindir'))
executable(
'wmenu',
files(
- 'main.c',
'menu.c',
'pango.c',
'pool-buffer.c',
'render.c',
'wayland.c',
+ 'wmenu.c',
+ ),
+ dependencies: [
+ cairo,
+ client_protos,
+ pango,
+ pangocairo,
+ rt,
+ wayland_client,
+ wayland_protos,
+ xkbcommon,
+ ],
+ install: true,
+)
+
+executable(
+ 'wmenu-run',
+ files(
+ 'menu.c',
+ 'pango.c',
+ 'pool-buffer.c',
+ 'render.c',
+ 'wayland.c',
+ 'wmenu-run.c',
),
dependencies: [
cairo,