summaryrefslogtreecommitdiff
path: root/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
new file mode 100644
index 0000000..130b4a0
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/CommonTables/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required (VERSION 3.6)
+
+project(CMSISDSPCommon)
+
+
+
+add_library(CMSISDSPCommon STATIC arm_common_tables.c)
+
+if (CONFIGTABLE AND ALLFFT)
+ target_compile_definitions(CMSISDSPCommon PUBLIC ARM_ALL_FFT_TABLES)
+endif()
+
+if (CONFIGTABLE AND ALLFAST)
+ target_compile_definitions(CMSISDSPCommon PUBLIC ARM_ALL_FAST_TABLES)
+endif()
+
+include(fft)
+fft(CMSISDSPCommon)
+
+include(interpol)
+interpol(CMSISDSPCommon)
+
+target_sources(CMSISDSPCommon PRIVATE arm_const_structs.c)
+
+configdsp(CMSISDSPCommon ..)
+
+### Includes
+target_include_directories(CMSISDSPCommon PUBLIC "${DSP}/../../Include")
+
+
+