summaryrefslogtreecommitdiff
path: root/Drivers/CMSIS/DSP/Source/SupportFunctions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Drivers/CMSIS/DSP/Source/SupportFunctions/CMakeLists.txt')
-rw-r--r--Drivers/CMSIS/DSP/Source/SupportFunctions/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/Drivers/CMSIS/DSP/Source/SupportFunctions/CMakeLists.txt b/Drivers/CMSIS/DSP/Source/SupportFunctions/CMakeLists.txt
new file mode 100644
index 0000000..4aae003
--- /dev/null
+++ b/Drivers/CMSIS/DSP/Source/SupportFunctions/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required (VERSION 3.6)
+
+project(CMSISDSPSupport)
+
+
+file(GLOB SRC "./*_*.c")
+
+add_library(CMSISDSPSupport STATIC ${SRC})
+
+configdsp(CMSISDSPSupport ..)
+
+### Includes
+target_include_directories(CMSISDSPSupport PUBLIC "${DSP}/../../Include")
+
+
+